В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DenZag
DenZag
21.01.2021 13:51 •  Информатика

Составить программу, которая бы по названию языка программирования выводила название этого языка. паскаль

Ответ:
Akhmed2387
Akhmed2387
03.10.2020 00:43
Const
  ru : array[1..33] of Char   =     ('а','б','в','г','д','е','ё','ж','з','и',
                                     'й','к','л','м','н','о','п','р','с','т',
                                     'у','ф','х','ц','ч','ш','щ','ъ','ы','ь',
                                     'э','ю','я');
  en : array[0..33] of String = (' ','a','b','v','g','d','e','ye','zh','z','i',
                                     'y','c','l','m','n','o','p','r','s','t',
                                     'u','f','h','c','ch','sh','sch','`','ы','',
                                     'ea','yu','ja');
{ транскрипцию записал не заглядывая ни в какие справочники - можете кидаться тапками }
 
Function GetIndex(ss : Char) : Byte;
Var ii : Byte;
Begin
  ii:=1;
  While (ii<=33) and (LowerCase(ss)<>ru[ii]) do Inc(ii);
  If ii in [1..33] then GetIndex:=ii else GetIndex:=0;
end;

Function Trans(S : String) : String;
Begin
  If Length(S)>0 then Trans:=en[GetIndex(S[1])]+Trans(Copy(S,2,Length(S)-1))
   else Trans:='';
end;

Begin
  Writeln(Trans('паскаль'));
  Writeln(Trans('ява'));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?