В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Нужно написать программу на языке паскаль дан массив из 10 целых чисел. определить, что больше: среднее арифметическое максимального и минимального элементов, или среднее арифметическое всех элементов массива.

Ответ:
слышала
слышала
07.09.2020 08:58
Var m : array[1..10] of Integer;
max,min,sum,i : Integer;
Begin
  min:=1; max:=1; sum:=0;
  For i:=1 to 10 do
  Begin
   m[i]:=Random(100);
   sum:=sum+m[i];
   If m[i]<m[min] then min:=i;
   If m[i]>m[max] then max:=i;
   Writeln(m[i]);
  end;
  Writeln('Ср.арифм. макс.и мин. элементов: ', (m[max]+m[min])/2);
  Writeln('Ср.арифм. всех элементов: ', sum/10);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?