В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
valerija1234
valerija1234
21.11.2020 23:28 •  Информатика

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(язык с++)

Ответ:
ЛераЛи123
ЛераЛи123
17.09.2020 12:55
#include <iostream>
using namespace std;
int main()
{   
int x, Max, Min;
x=Max=Min=0;
for (int i=1;i<=15;++i) {   
cin >> x;   
if (x > Max) Max=x;   
if (x < Min) Min=x;
}
cout << "Максимальное положительное число " << Max << " Минимальное отрицательное число " << Min << endl;
if (Max == 0 or Min == 0)    cout  << "Число 0 означает что такого значения нет" << endl;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?