В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Monika950
Monika950
01.03.2021 15:05 •  Информатика

Составить программу, в которой получить как можно больше слов, образованных из слова информатика. вывести на экран длину исходного слова. (программа на языке паскаль, использовать команды: length, copy, delete, insert, concat.) желательно сделать до завтрешнего дня, информатика завтра будет. заранее )

Ответ:
superschool1
superschool1
03.10.2020 00:06
Из слова "информатика" так много всего можно сделать!
Вот небольшая часть:
var s,s1:string;
begin
s:='информатика';

s1:=copy(s,3,5);
writeln(s1,'-',length(s1));

s1:=s;delete(s1,8,4);
delete(s1,1,2);
writeln(s1,'-',length(s1));
//3
s1:=s;delete(s1,1,5);
delete(s1,3,2);
insert(copy(s,5,1),s1,3);
writeln(s1,'-',length(s1));
//4
s1:=copy(s,5,1)+copy(s,4,1)+copy(s,6,2)+copy(s,2,1)+copy(s,8,3);
writeln(s1,'-',length(s1));
//5
s1:=concat(copy(s,3,3),copy(s,8,1));
writeln(s1,'-',length(s1));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?