В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
wehhc
wehhc
03.01.2022 22:14 •  Информатика

Написать программу, которая для заданного n определяет, сколько нулей стоит в конце числа n! . (предполагается, что n достаточно велико и непосредственное вычисление функции n! умножением невозможно).

Ответ:
ApuCTokpaT1
ApuCTokpaT1
03.10.2020 00:05
Заметим, что число нулей в записи числа = максимальная степень десятки, на которую делится число = минимальная из степеней двойки и пятерки, входящих в разложение на простые множители этого числа. [Первое равенство очевидно, второе можно доказать от противного]
Например, 7500 имеет на конце 2 нуля: 7500 = 2^2 * 3 * 5^4 - минимальная из степеней двойки и пятерки как раз 2.

В разложении числа N! на простые множители пятерок всегда не больше, чем двоек: если в выражении N!=1*2*3*.,,*N есть множитель вида m*5^k, то есть и множитель m*2^k - хотя бы потому, что второе число меньше первого, а факториал - это произведение всех чисел меньше заданного. Поэтому при разложении на простые множители степень двойки хотя бы степень двойки. Используя наблюдение из первого параграфа, получаем:
Число нулей в конце десятичной записи числа N! совпадает с числом пятерок в разложении числа N! на простые множители.

Остается найти число пятерок в разложении. Проще всего это понять на примере.
26! = 1 * 2 * 3 * 4 * 5 * 6 * 7 * 8 * 9 * 10 * 11 * 12 * 13 * 14 * 15 * 16 * 17 * 18 * 19 * 20 * 21 * 22 * 23 * 24 * 25 * 26

Число чисел, делящихся на 5, среди первых 26 чисел равно пяти (это 5, 10, 15, 20, 25). Это число можно найти, округлив вниз результат от деления 26/5.
Если подумать, можно понять, что в разложении 26! на простые множители 5 встретится не 5 раз - мы забыли учесть число 25, которое даст не одну пятерку, а две. И вообще, в ответ сомножитель что-то*5^n будут давать n пятерок.

Итого ответ для произвольного N: [N/5] + [N/5^2] + [N/5^3] + ...

Алгоритм:
c = 0
пока [N/5] > 0:
   увеличиваем c на [N/5]
   N = [N/5]
вывод c

Питон-3:
N = int(input())
c = 0
while N//5 > 0:
   c += (N//5)
   N = N//5
print(c)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?