Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
2003247
23.01.2023 18:23 •
Информатика
Написать программу в паскале (вводить числа до тех пор пока очередное не окажется равно 0,найти сумму чисел с четным порядковым номером)
Ответ:
sxmax
17.09.2020 10:42
Var a,i,s:integer;
begin
write('a='); readln(a);
s:=0;i:=1;
while a<>0 do
begin
if i mod 2 =0 then s:=s+a;
i:=i+1;
write('a='); readln(a);
end;
writeln('s=',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
МамкаДраконов
29.03.2022 07:15
Вам дается число n, которое состоит из цифр 9 и 6. Вам нужно выбрать ровно одну цифру и перевернуть ее (если перевернут 9, то получится 6 и наоборот). Например, если n равно 96996...
lera24012002
13.07.2020 20:42
Вам дается натуральное число N. Узнайте, существует ли такое натуральное число K, что K×(K−1)/2=N.В единственной строке задается натуральное число N (1≤N≤10^9).Если существует...
марлен223
26.08.2022 11:42
11. Скласти програму мовою програмування Python, яка обчисло периметр прямокутника.12. Скласти програму мовою програмування Python, яка з двох цілих чиселпоказує більше (максимум...
alinasad337
02.12.2021 01:27
Усучасній інформаційній системі роль аппаратно-програмної частини відіграє...
alyonaSidorenk
25.11.2022 00:54
Написать програму по для паскаля. определить количество сетки (b), которой необходимо загородить сад прямоугольной формы, со сторонами а и b метров и количество минеральных удобрений...
goooooooooj
25.11.2022 00:54
1. раскодируйте текст с алгоритма lz78: (0,x), (0,y), (2,x), (1,y), (0,z), (1,z), (5,y), (0,x). 2. раскодируйте текст с алгоритма lz78: (0,x), (0,y), (0,z), (3,z), (2,x), (4,z),...
PAMAGITE12
25.11.2022 00:54
Вкодировке unicode на каждый символ отводится два байта. определи информационный объём текста из 31 символов в этой кодировке....
telytnikovalenp0apjm
25.05.2020 20:27
Выполните арифметическое действие. В ответе укажите получившееся число, основание системы счисления указывать не нужно. 1010001 2* 11011 2...
дарууунчик
29.06.2022 04:09
Составить программу для решения следующей . из строки выбрать все цифры и сформировать другую строку s=sdfg745tg2345dfg74 m=7452234574...
Wkdj13737
04.12.2021 11:16
Составьте музыкальную галерею произведений, драматургия которых строится на чувстве любви!...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('a='); readln(a);
s:=0;i:=1;
while a<>0 do
begin
if i mod 2 =0 then s:=s+a;
i:=i+1;
write('a='); readln(a);
end;
writeln('s=',s);
end.