В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
3523512
3523512
30.12.2020 17:08 •  Информатика

Составьте программу, которая позволяет проверить правописание "жи" и "ши" в тексте и выводит на экран количество допущенных ошибок и исправленную строку

Ответ:
dashasm06
dashasm06
17.09.2020 07:55
Procedure GhiShi(Var S : String; Var N : Byte);
Var i : Byte;
Begin
  N:=0;
  For i:=1 to Length(S)-1 do
    If (S[i] in ['ж','ш']) and (S[i+1]='ы') then
    Begin
      S[i+1]:='и';
      Inc(N);
    end;
end;

Var St : String;
k : Byte;
Begin
  { Readln(St); }  St:='"жы" и "шы" пишы через "и"';
  GhiShi(St,k);
  Writeln(St);
  Writeln('Количество ошибок: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?