В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
danik24rysskiy
danik24rysskiy
23.05.2023 12:18 •  Информатика

Написать программу в turbo pascal найти 2 максимума из любой последовательности чисел

Ответ:
reginailt
reginailt
02.10.2020 23:46
Var ar:array[1..30] of integer;
i,max,max2,maxp,maxi:integer;
begin;
randomize;
writeln('Array');
for i:=1 to 30 do
begin;
ar[i]:=random(1,100);
write(ar[i]:4);
end;
for i:=1 to 30 do
if max<ar[i] then
begin;
maxp:=max;
max:=ar[i];
maxi:=i;
end;
ar[maxi]:=maxp;
for i:=1 to 30 do
if max2<ar[i] then max2:=ar[i];
writeln;
writeln('Max1:',max);
writeln('Max2:',max2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?