Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
alistas
01.05.2021 00:50 •
Информатика
Напишите программу для паскаля! дано натуральное число. найти число, получаемое удалением удалением из исходного всех цифр а.
Ответ:
6г56г
07.09.2020 08:26
Var n,m,k,p,a:integer;
begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n<>0 do
begin
k:=n mod 10;
if k<>a then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln('m=',m);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
yanemykina2014
16.12.2022 05:08
Запись некоторого натурального числа х в шестнадцатеричной системе счисления имеет ровно три значащих разряда. это число увеличили в два раза, и оказалось, что запись получившегося...
HAHHSSAGSGAGS
16.12.2022 05:08
Придумайте новый вид информационных услуг....
olesyamolyanova
07.06.2021 18:29
напишите программу на языке программирования Паскаль для решения след. задачи :даны два целых числа, найти квадрат суммы этих чисел. ...
Mariyana10
22.02.2022 17:14
Шарик массой 0,05 кг во время прямолинейного равномерного движения изменяет свою скорость от 3 м/с до 5 м/с. Найдите изменение импульса. 1. 0,3 кг⸱м/с 2. 0,4 кг⸱м/с 3. 0,1...
Black13495
14.03.2022 11:18
Замок сейфа открывается, если введена правильная комбинация. Преступник пытается открыть сейф, набирая код наудачу. Он знает, что код состоит из цифр 1, 2, 3, 4, 5, 6 при...
1Продавец1
22.02.2022 17:14
Коля пишет Оле Оля пишет Коле План 2 глав Клетка без птицы Холмик во дворе...
isadulla
22.02.2022 17:14
Какое значение имеет Солнце для бактерий....
sasharyabukhina
22.02.2022 17:14
1.Как вы понимаете словосочетание реформа сверху? Являлась ли , на Ваш взгляд , отмена крепостного права такой реформой сверху ? 2.Дайте собственную оценку проведённых Александром...
ArtemPlayGames
14.03.2022 11:18
Можно ли было остановить процесс распада СССР умоляю напишите подробно без спама, если ответ хороший отмечу как лучший ответ....
вит39
14.03.2022 11:18
Решите уравнение 0,25:(х-8)=6,2:2,5...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('n='); readln(n);
write('a='); readln(a);
m:=0;p:=1;
while n<>0 do
begin
k:=n mod 10;
if k<>a then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln('m=',m);
end.