Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ghukasyangoar
05.12.2022 14:28 •
Информатика
C++ сформировать одномерный массив из количества положительных элементов матрицы
Ответ:
meduzakoy4kla
16.09.2020 23:18
#include <iostream>
using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
hoggarthtanya
09.02.2021 05:03
Запрашивайте у пользователя размер наследства, которое вы бы хотели получить ( в долларах), и сумму денег , которую вы собираетесь тратить в месяц.выведите на экран время...
Babikovandrei48
09.02.2021 05:03
Слово из 14-ти букв - этап подготовки документа на компьютере, при котором вы просматриваете его, исправляете обнаруженные ошибки и вносите необходимые изменения....
ymnik3345
17.04.2022 02:21
Https://thriveglobal.com/authors/365-dni-days-2020-hd-full-movie-online-free-1 https://thriveglobal.com/authors/123movies-365-dni-days-hd-full-watch-online-free https://thriveglobal.com/authors/full-watch-365-dni-days-2020-online-hd-free-1...
Мижоп
26.08.2020 02:38
ЯЗЫК ПАСКАЛЬ, Рассчитать надбавку к зарплате за стаж, если стаж от 2 до 5 лет, надбавка составляет S1 руб., если стаж от 5 до 10 лет – S2 руб. Ввести с клавиатуры зарплату...
milayakisa1
07.05.2022 05:31
Всистемах счисления с основанием больше 10 для представления чисел после цифр 0,1,2,…,9 используют латинские буквы в алфавитном порядке: a, b, c и т. д. какое число соответствует...
mrlolik1500
02.05.2022 06:30
130 (в десятичной) в двоичной системе счисления 3442 (в пятичной) в двоичной системе счисления762 (в восьмиричной) + 762 (в восьмиричной) в двоичной системе счисления...
uzinalizs
02.05.2022 06:30
Сколько существует вариантов составления букета из семи роз красного и белого цвета...
nyurachernikov
19.05.2022 05:36
3. Что такое сфера? ответье...
LOSS903903
28.03.2021 01:01
. Статья, набранная на компьютере, содержит 32 страницы, на каждой странице 40 строк, в каждой строке 64 символа. Определите размер статьи в кодировке КОИ-8, в которой каждый...
vansob2003
21.01.2021 21:01
Описать комнату используя конструкции were is/were are (около 30 предложений) 99...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}