В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lezgin228
Lezgin228
09.03.2020 20:01 •  Информатика

Необходимо написать программу сложения двух матриц произвольной размерности, предусмотреть проверку возможности сложения. программа написана не верно, исправить ошибки. type mass=array[1..10,1..10] of real; var a,b,c: mass; n,m,i,j,n1,m1: integer; procedure matra (var a: mass); var n,m,i,j: integer; begin for i: =1 to n do for j: =1 to m do writeln('a[',i,',',j,']: '); readln(a[i,j]); end; procedure matrb (var b: mass); var i,j,n1,m1: integer; begin for i: =1 to n1 do for j: =1 to m1 do writeln('b[',i,',',j,']: '); readln(b[i,j]); end; procedure sum(a,b,c: mass); var i,j,n,m: integer; begin for i: =1 to n do for j: =1 to m do c[i,j]: =a[i,j]+b[i,j]; end; begin writeln('введите n,m матрицы a'); readln(n,m); matra(a); writeln('введите n,m матрицы b'); readln(n1,m1); matrb(b); if (n1< > n) and (m1< > m) then writeln('матрицы сложить нельзя'); readln; sum(a,b,c); writeln('a+b'); for i: =1 to n do begin for j: =1 to m do write(c[i,j]: 1: 3, ' '); writeln; end; readln; end.

Ответ:
WseNikiZanyati
WseNikiZanyati
16.09.2020 20:57
Type
  mass = array[1..10, 1..10] of real;

var
  a, b, c: mass;
  n, m, i, j, n1, m1: integer;

procedure MatrA(var a: mass);
var
  i, j: integer;
begin
  for i := 1 to n do
    for j := 1 to m do
    begin
      writeln('a[', i, ',', j, ']: ');
      readln(a[i, j])
    end
end;

procedure MatrB(var b: mass);
var
  i, j: integer;
begin
  for i := 1 to n1 do
    for j := 1 to m1 do
    begin
      writeln('b[', i, ',', j, ']: ');
      readln(b[i, j])
    end
end;

procedure Sum(a, b: mass; var c: mass);
var
  i, j: integer;
begin
  for i := 1 to n do
    for j := 1 to m do
      c[i, j] := a[i, j] + b[i, j];
end;

begin
  writeln('Введите n,m матрицы A');
  readln(n, m);
  MatrA(a);
  writeln('Введите n,m матрицы B');
  readln(n1, m1);
  MatrB(b);
  if (n1 <> n) and (m1 <> m) then
    writeln('Матрицы сложить нельзя')
  else begin
    Sum(a, b, c);
    writeln('A+B');
    for i := 1 to n do
    begin
      for j := 1 to m do
        write(c[i, j]:1:3, ' ');
      writeln
    end
  end;
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?