Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
amira061
23.11.2021 08:57 •
Информатика
Составить программу ,которая находит наименьшее натуральное n, при котором 2n> = 20 (2 в степени n ), и результат наименьшеечисло n - выводит на экран
Ответ:
Самолеееет555
16.09.2020 19:51
Var n,a:integer;
begin
n:=1;
a:=2;
repeat
for i:=1 to n do
a:=a*2;
n:=n+1;
until a>=20;
writeln(n)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Sergey15211
20.10.2021 19:21
Число 1100000 в восьмиразрядном представлении имеет вид...
Aminka210102
04.04.2023 04:37
Внимание! Это задачу нужно решать на C# :) Новое приключение Рика и Морти. Мошенники завладели секретной информацией. И чтобы их не нашли начали перемещаться между галактиками...
ruslana0506
20.08.2021 21:14
Для чего роботу нужен датчик? При датчиков, робот можетпревращаться в кого-нибудьПри датчиков робот можетчитать мысли человека на расстоянииДля красоты, чтобы его хотелось всемкупитьПри...
Vanya543q
22.11.2022 01:38
2. Алгоритм, в котором переменной Y присваивается значение наибольшей из трех величин A,B,C....
Nika5332
05.01.2021 00:05
Что общего в питании простейших губок и кишечнополостных...
xoxoberrmi11
05.01.2021 00:05
Дано: треугольник авс, угол в=90 градусов ас = 25 см, ав = 7см. найти: sin, cos, tg угла а; sin, cos, tg угла в...
ksapko
28.04.2020 06:26
Определите регион россии по его краткому описанию.эта область,расположенная в европейской части россии,не имеет выход к государственной границе рф и не имеет выхода к морю.территория...
Rf123123
05.01.2021 00:05
Уотца двое сыновей.он старше старшего сына в 3 раза и старше младшего на 40 лет. старший сын старше младшего втрое.сколько лет старшему брату ?...
ivkov2003
30.03.2023 17:17
Какое количество теплоты необходимо для нагревания 250 г воды от -10с до кипения?...
френкинштеин
12.04.2020 12:17
Кконцам лёгкого стержня длиной 60 см подвешены гири весом 1н и 5н.в какой точке нужно подвесить этот стержень,чтоб он был в равновесии в горизонтальном положении?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
n:=1;
a:=2;
repeat
for i:=1 to n do
a:=a*2;
n:=n+1;
until a>=20;
writeln(n)
end.