В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2285811
2285811
09.06.2022 10:16 •  Информатика

Составьте программу, которая формирует массив из 12 случайных чисел на промежутке от -40 до 10 и находят элементы, большие -10 и меньше 5

Ответ:
kall4
kall4
26.05.2020 17:48

Program Program1;
Var
i:integer;
a:array [1..12] of integer;
begin
randomize;
for i:=1 to 12 do
a[i]:=random(51)-40;
writeln;
writeln('Элементы больше -10:');
for i:=1 to 12 do
if a[i]>-10 then write('a[',i,']=',a[i],', ');
writeln;
writeln('Элементы меньше 5:');
for i:=1 to 12 do
if a[i]<5 then write('a[',i,']=',a[i],', ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?