В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1Booooooooooom1
1Booooooooooom1
17.08.2021 10:24 •  Информатика

Решить 2 в паскале: 1)определить равны ли все цифры заданного пятизначного числа. 2)каждое число фибоначчи вычисляется как f1=0, f2=1, а начиная с третьего по формуле fn=fn-1+fn-2. составить программу, которая вычисляет n чисел фибоначчи.

Ответ:
Zagadochnaya
Zagadochnaya
16.09.2020 18:19
1.
Function Check(A : Longint) : Boolean;
Begin
 If A>9 then Check:=((A mod 10)=(A div 10 mod 10)) and Check(A div 10) else Check:=True;
end;
Var N : Longint;
Begin
  Readln(N);
  Writeln(Check(N));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?