В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Карнова
Карнова
19.07.2020 07:58 •  Информатика

Напишите программу ): ввести 15 целых элементов массива, элемента с нечетными номерами увеличить на 10, элементы с четными номерами уменьшить на 10. вывести на экран

Ответ:
narutoudzumaki228
narutoudzumaki228
30.08.2020 14:18
USES CRT;
VAR A:array[1..15] of integer;
    i:integer;
BEGIN
CLRSCR;

{Заполняем массив}
For i:=1 to 15 do
 begin
   Write('Введите ',i,' элемент массива  ');
   Read(A[i]);
   CLRSCR;
 end;

{Выводим массив на экран}
For i:=1 to 15 do
 Write(A[i],'   ');

{К нечетным номерам массива +10 к четным -10}
For i:=1 to 15 do
 if i mod 2 <>0 then A[i]:=A[i]+10
                else A[i]:=A[i]-10;

Writeln;

{Выводим на экран измененный массив}
For i:=1 to 15 do
 Write(A[i],'   ');

Readln;
READLN;
END.
Напишите программу ): ввести 15 целых элементов массива, элемента с нечетными номерами увеличить на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?