В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Deniska7771
Deniska7771
16.02.2023 04:46 •  Информатика

Написать программу , которая заполняет элементами массив по правилу: а(i)= (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив , в котором заменены на противоположные знаки элементов исходного массива . i=1,2,

Ответ:
Никита8547
Никита8547
30.08.2020 14:17
Var a:array[1..10]of Integer;
i,k:Integer;
p:LongInt;
begin
p:=1;
k:=0;
Writeln('Сгенерированный массив:');
Randomize;
for i:=1 to 10 dobegina[i]:=Random(10)+1;if a[i] mod 2=1 then p:=p*a[i] else k:=k+1;
Write(a[i],' ');
end;
Writeln;
Writeln('Произведение нечетных:',p);
Writeln('Количество четных:',k);
Readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?