В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TheATN
TheATN
13.10.2021 21:29 •  Информатика

Склавиатуры вводят слово и символ. составьте программу, которая: а) проверяет, есть ли в этом слове данный символ; б) определяет позицию заданного символа; в) подсчитывает колличество вхождений заданного символа.

Ответ:
Anfisac3t
Anfisac3t
23.05.2020 18:09

var
slovo,simval:string;
i,k:integer;
begin
k:=0;
write('vvedite slovo ');
readln(slovo);
write('vvedite simval ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
writeln('YES vstre4aets9 ',k,' raz, na pozicii ',i)else writeln('NO');
writeln;
end.

вот в одном решении

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?