Войти
Регистрация
Спроси ai-bota
В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Показать больше
Показать меньше
райымбек42
16.04.2022 08:15 •
Информатика
(паскаль авс): среди натуральных трехзначных чисел найти те, сумма цифр которых равна заданному числу а, а само число при делении на 4 дает остаток 3.
Ответ:
chovganirina
19.08.2020 06:50
Var a,b,i,s1,s2,s3:integer;
begin;
readln(a);
for i:=100 to 999 do
begin;
b:=i;
s1:=b mod 10;
b:=b div 10;
s2:=b mod 10;
b:=b div 10;
s3:=b mod 10;
b:=b div 10;
if (i mod 4=3) and (s1+s2+s3=a) then writeln(i);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Erumbumbum
15.11.2020 05:58
Банковские проценты Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Определите, через сколько лет...
Asilkhab5509
01.10.2021 14:13
Написать программу на паскале. создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы. ....
манюня5649
04.04.2021 15:36
В одномерном массиве X(10) из положительных и отрицательных чисел найти: количество отрицательных элементов в первой половине массива, поставить найденное значение на место...
РосАлик
03.10.2022 02:12
Покажите, как в память компьютера будет записано число: –122....
den193p08o5z
04.07.2021 10:20
Составить алгоритм поиска четырёхзначного числа, начинающегося с единицы и такого, что если переставить эту цифру в конец записи числа, то получится число, в три раза большее...
pro100miss
02.08.2022 14:31
Принцип запись : жёсткий диск, флешку, магнитный диск (дискета) , бумага с записями, книга....
Adele04
24.06.2020 06:58
Запишите значение переменной s, полученное в результате работы следующей программы. var s, n: integer; begin s : = 5; for n : = 2 to 4 do s: = s + (n-1); writeln(s); end....
qamqsmbfhfuc
12.06.2022 13:42
. Ergänzt die Satze. . Die Mutter weckt ... (das Kind).. Die Oma weckt ... (der Bruder).. Der Opa weckt ... (die Oma).. Der Vater weckt ... (die Mutter)....
kamikot
12.06.2022 13:42
Які можливі значення x при виразі 4x^2-9/x^3-9x...
Valeriiiss
12.06.2022 13:42
Прочитай текст и отметь те утверждения после него, которые соответствуют содержанию (T). English school year has three terms, three months each. The names of the termsare autumn...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin;
readln(a);
for i:=100 to 999 do
begin;
b:=i;
s1:=b mod 10;
b:=b div 10;
s2:=b mod 10;
b:=b div 10;
s3:=b mod 10;
b:=b div 10;
if (i mod 4=3) and (s1+s2+s3=a) then writeln(i);
end;
end.