В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Joom372
Joom372
01.03.2022 02:20 •  Информатика

Написать программу, которая запрашивает массив из n целых чисел, а затем складывает все элементы с нечетными номерами и все элементы с четными номерами и выводит их сумму, а также сам исходный массив. !

Ответ:
Jefry228
Jefry228
07.09.2020 07:40
Program al;
const n=10;
var a:array[1..n] of integer;
s,s1,s2,i:integer;
begin
writeln('vvedite danniy massiv=');
for i := 1 to n do
readln(a[i]);
s:=0;
s1:=0;
s2:=0;
for i := 1 to n do 
if i mod 2=0 then s1:= s1+a[i] else
begin 
s2:=s2+a[i];
s:=s1+s2;
end;
writeln('ishodniy massiv=');
for i := 1 to n do
write (a[i]:4);
writeln(' summa=',s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?