В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Нурлы11
Нурлы11
25.08.2022 09:03 •  Информатика

Составьте программу которая устанавливала бы нахождение повторяющихся букв в слове , т.е. показывала есть или нету .

Ответ:
alina1abikeeva
alina1abikeeva
16.09.2020 08:50
Вот решение на паскале ABC, если нужно на другом языке программирования. Напишите на почту.
var
  a:string;
  c:char;
  n,i,i1:integer;
begin
  readln(a);
  for i:=1 to length(a) do begin
    c:=a[i];
    for i1:=i+1 to length(a) do begin
      if c = a[i1] then n:=n+1;
    end;
  end;
  if n>0 then writeln('В слове ',n,' пар букв') else writeln('Буквы не повторяются')
 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?