В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
chamich
chamich
26.06.2021 01:14 •  Информатика

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел. написать в паскале.

Ответ:
jcyueurur
jcyueurur
02.10.2020 22:39
Var s1,s2:string;
begin;
writeln('Введите исходные знаки');
readln(s1);
readln(s2);
if ((s1<>'-') and (s1<>'+')) or ((s2<>'-') and (s2<>'+')) then
begin;
writeln('Ошибка');
exit;
end;
if ((s1='+') and (s2='+')) or ((s1='-') and (s2='-')) then writeln('+') else writeln('-');
end.

С числами:
var a,b:integer;
begin;
writeln('Делимое:');
readln(a);
writeln('Делитель');
readln(b);
if b=0 then
begin;
writeln('Нельзя делить на ноль. Если это, конечно, не JavaScript.');
exit;
end;
if a=0 then
begin;
writeln('0');
exit;
end;
if ((a>0) and (b>0)) or ((a<0) and (b<0)) then writeln('+') else writeln('-');
end.
0,0(0 оценок)
Ответ:
Alena200302
Alena200302
02.10.2020 22:39
Var
  a,b:real;
begin
  Write('Введите через пробел два числа: '); Read(a,b);
  if b=0 then Writeln('Результат деления не определен')
  else
    if a*b>0 then Writeln('Частное a/b имеет положительный знак')
    else
      if a=0 then Writeln('Частное a/b равно нулю')
      else Writeln('Частное a/b имеет отрицательный знак')
end.

Тестовое решение:
Введите через пробел два числа: 8 -4
Частное a/b имеет отрицательный знак
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?