В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DanilWolf
DanilWolf
02.04.2023 00:36 •  Информатика

1)напишите программу, которая вводит натуральное число n и нахо дит сумму всех натуральных чисел от 1 до n. используйте сначала цикл с условием, а потом — цикл с переменной.2)напишите программу, которая вводит натуральное число n и выво дит первые n чётных натуральных чисел.3)напишите программу, которая вводит натуральные числа а и ь, и выводит квадраты натуральных чисел в диапазоне от а до ъ. напри мер, если ввести 4 и 5, программа должна вывести: 4 * 4=16 5 * 5=25

Ответ:
yanakrl1
yanakrl1
02.10.2020 22:32
(Pascal)
1.
var
  i, s, n: integer;
begin
  readln(n);
  s := 0;
  i := 0;
  while i < n do
  begin
    i := i + 1;
    s := s + i;
  end;
  writeln('Цикл с предусловием: ', s);
  s := 0;
  i := 1;
  repeat
    s := s + i;
    i := i + 1;
  until i > n;
  writeln('Цикл с постусловием: ', s);
  s := 0;
  for i := 1 to n do
    s := s + i;
  writeln('Цикл с переменной: ', s);
end.

2.
var
  i, n: integer;
begin
  readln(n);
  for i := 1 to n do
    write(2 * i, ' ')
end.
3.
var
  i, a, b: integer;
begin
  readln(a, b);
  for i := a to b do
    writeln(i, ' * ', i, ' = ', i * i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?