В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
STALKER147
STALKER147
27.04.2020 05:51 •  Информатика

Написать программу в паскале 8)найдите хотя одно натуральное число, которое делится на 11, а при делении на 2, 3, 4, 10 дает в остатке 1

Ответ:
Марго22111
Марго22111
31.07.2020 01:52
Const N=11;
var i,d,k:integer;
begin
  k:=0;
  repeat
  k:=k+N;
  d:=0;
  for i:=2 to 10 do if k mod i = 1 then d:=d+1;
  until (d=9) or (K>32000);
  if d=9 then writeln('Искомое число = ',K)
         else writeln('Число не найдено');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?