В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lika4072004
Lika4072004
15.02.2021 23:53 •  Информатика

Нужно до 22.00 05.11.! написать программу, которая заменяет цифру числа названием этой цифры. например, заменить число 4563 на строку четыре пять шесть три.

Ответ:
супермарио3
супермарио3
31.07.2020 01:48
Var
  n: integer;
  answer: string;
 
begin
  read(n);
  while n > 0 do {Пока есть цифры добавляем последнюю цифру числа к ответу и отбрасываем ее}
  begin
    case n mod 10 of
      0: answer := 'ноль ' + answer;
      1: answer := 'один ' + answer;
      2: answer := 'два ' + answer;
      3: answer := 'три ' + answer;
      4: answer := 'четыре ' + answer;
      5: answer := 'пять ' + answer;
      6: answer := 'шесть ' + answer;
      7: answer := 'семь ' + answer;
      8: answer := 'восемь ' + answer;
      9: answer := 'девять ' + answer;
    end;
    n := n div 10;
  end;
  writeln(answer);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?