Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
anasteishamrrr
14.09.2022 16:03 •
Информатика
Найти наибольший элемент двумерного массива. в паскале. обязательно использовать функцию или процедуру
Ответ:
мажорчик2
31.07.2020 01:25
Const n=5;
var i,j:integer;
a:array[1..n,1..n] of integer;
Max:integer;
procedure p_max(input_mass:integer);
begin
if input_mass>Max then
Max:=input_mass;
end;
//Заполняем массив
procedure zapolnenue;
var i,j:integer;
begin
for i:=1 to n do
for j:=1 to n do
a[i,j]:=Random(1000);
end;
begin
Randomize;
zapolnenue;
writeln('Массив:');
for i:=1 to n do
begin
for j:=1 to n do
begin
write(a[i,j],' ');
p_max(a[i,j]);
end;
writeln;
end;
writeln;
writeln('Max = ',Max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
NastasS4
23.04.2020 16:17
Итак и с этим у меня проблемы. ? (1 часть)...
CatMyBoss
03.12.2020 06:17
Как изменить размер и цвет символа, вставленного из библиотеки символов?(Word)...
1Данил111
14.04.2023 09:10
Какой ответ? 1, 2, 3 или 4?...
сонка123456789
12.01.2023 01:32
Найти площадь кольца, внутренний радиус которого равен 20, а внешний -заданному числу r (r 20). паскал...
ntaskaeva2
12.01.2023 01:32
Какие средства информации ты знаешь? какими она передается? придумать форму передачи информации о правилах поведения в школе - текстовую, в знаках или рисунках. 3 класс технология...
qqruzko
02.07.2021 08:09
Решить при состовлении сообщения использовали 64 символьный алфавит каким будет информационный объекттакого сообщения в байтах если оно содержит 4096символов...
exhedzo
22.08.2020 21:30
6. информационный объем текста 512 байт. определите количество символов в нем. a) 16 b) 8 c) 64 d) 512...
яло203
28.11.2020 10:07
Составить программу определения ,является ли число х ,введенное с клавиатуры : 1)не кратным 8 2)x принадлежит (-60; 50)...
dashanovikova03
28.11.2020 10:07
Какой объем видеоданных будет передан за 30 секунд с видеопамяти на монитор, если монитор работает в режиме с разрешением 1024х768 пикселей, глубиной цвета 24 бита и частотой...
helpme177
31.03.2021 23:04
ответьте на вопросы по притче О Блудном сыне .Прав ли отец, обрадовавшийся возвращению сына и устроивший праздник?И почему?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var i,j:integer;
a:array[1..n,1..n] of integer;
Max:integer;
procedure p_max(input_mass:integer);
begin
if input_mass>Max then
Max:=input_mass;
end;
//Заполняем массив
procedure zapolnenue;
var i,j:integer;
begin
for i:=1 to n do
for j:=1 to n do
a[i,j]:=Random(1000);
end;
begin
Randomize;
zapolnenue;
writeln('Массив:');
for i:=1 to n do
begin
for j:=1 to n do
begin
write(a[i,j],' ');
p_max(a[i,j]);
end;
writeln;
end;
writeln;
writeln('Max = ',Max);
end.