В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
кемпінг
кемпінг
16.02.2021 00:07 •  Информатика

Необходимо написать программу в паскале вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.

Ответ:
Kek346582
Kek346582
31.07.2020 01:15
Var
  a:array[1..10] of integer;
  n,i:integer;
begin
  readln(n);
  for i:=1 to 10 do begin
    a[i]:=random(-10,10);
    if (a[i] < 0) and (i > 1) then begin
      if a[i-1] > 0 then a[i-1]:=n;
    end;
    if (a[i] < 0) and (i = 1) then write(n:3);
  end;
    for i:=1 to 10 do write(a[i]:3);
end.
0,0(0 оценок)
Ответ:
alena250880
alena250880
31.07.2020 01:15
Pascal ABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?