В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nushales
nushales
07.02.2020 00:04 •  Информатика

Напишите программу которая принимает с клавиатуры целое число часов и выводит на экран! ​

Ответ:
twilightsun90
twilightsun90
23.03.2019 11:50

type cl = class

  a: integer;

  constructor create(b: integer);

  procedure setval(b: integer);

  function getval: integer;

  procedure sq;

end;

constructor cl.create(b: integer);

begin

  a : = b;

end;

procedure cl.setval(b: integer);

begin

  a : = b;

end;

function cl.getval: integer;

begin

  getval : = a;

end;

procedure cl.sq;

begin

  if a < 0 then

    writeln('a ^ 2 = ', a * a)

  else

    writeln('error');

end;

var

  obj: cl;

  a : integer;

begin

  write('a = ');

  readln(a);

  obj : = cl.create(a);

  obj.sq;

  readln;

  obj.destroy;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?