В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
raisabarsegyan
raisabarsegyan
01.10.2022 02:50 •  Информатика

Составить программу решения ах2+вх+с=0,а,в не равно нулю.проверить случай ,когда дискриминант болmше нуля меньше нуля и равен нулю.

Ответ:
Ovaliza
Ovaliza
30.07.2020 18:17
 program ii;  
                var A, B, C, D: real; 
                  begin   
  writeln ('Введите коэффициенты А, В, С'); 
   readln (A, B, C);   
  if A=0     then
 writeln ('Уравнение не квадратное')
     else
begin
 D := B*B - 4*A*C; 
A := 2*A;
if D<0 then
writeln ('Действительных корней нет')
else
 if D=0 then
writeln ('Корни равны: X1 = X2 = ', -B/A)
else 
   begin       
  D := sqrt(D);      
    writeln ('X1 = ', (-B+D)/A);writeln ('X2 = ', (-B-D)/A); 
  end;        end;              end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?