В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sofusavihc1289
sofusavihc1289
09.05.2022 22:32 •  Информатика

Дан числовой массив а, состоящий из n натуральных чисел. определите количество элементов массива, которые при делении на 7 остаток 1, 2 или 5.

Ответ:
dum3
dum3
02.10.2020 22:11
Const
N = 7;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
j:=0;
WriteLn('Введи массив A(N)');
For i:= 1 to N do
 Begin
 Read(A[i]);
 if (A[i] mod 7 =1)or(A[i] mod 7 =2)or(A[i] mod 7 =5) then j:=j+1
 End;
WriteLn(j)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?