В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
issirisoyf2q6
issirisoyf2q6
24.08.2022 12:02 •  Информатика

Напишите программу, которая по введенному не более чем 4-х значному числу k будет выдавать сумму его цифр. на входе k(0< =k< =9999).

Ответ:
Lisonьka124
Lisonьka124
30.07.2020 11:20
var
k,s: integer;
begin
Writeln('Введите число K:');
Readln(k);
if (k<=9999) and(k>=0) then
begin
if k div 1000 <>0 then
 s:= (k mod 10) + (k div 1000) + ((k  div 100)mod 10) + (k div 10)mod 10;
if (k div 1000 = 0)  and (k div 100 <> 0) then
s:=(k mod 10) +( k  div 100) + (k div 10)mod 10;
if (k div 100 = 0)  and (k div 10 <> 0) then
s:= (k mod 10) + (k div 10); 
if (k div 10 = 0)  and (k mod 10 <> 0) then
s:= k;Writeln('Сумма цифр = ', s);
end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?