В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
leoni008p08nm5
leoni008p08nm5
13.09.2020 08:03 •  Информатика

Составить программу на паскале. дано натуральное число: а) найти количество четных цифр; б) верно ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.

Ответ:
Ekaterina785
Ekaterina785
02.10.2020 21:50
Var a,b,c,c1,a1:integer;
begin
write('введите число => ');
readln(a);
write('введите число а => ');
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln('количество чётных цифр =>', c);
if (c1>2) then writeln('а встречается в числе больше двух раз');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?