В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Napol28
Napol28
05.01.2021 12:58 •  Информатика

1. напишите программу, которая определяет сумму цифр 3-х числа. например : 5+4div+8=17 2. напишите программу , которая произведение чисел 3-х ( 548 ➡️ 160)

Ответ:
egortupi
egortupi
02.10.2020 21:44
//PascalABC.Net 3.0, сборка 1053
var
  n,s,p:integer;
begin
  Write('Введите натуральное трехзначное число: '); Read(n);
  s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
  p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
  Writeln('Сумма цифр числа равна ',s);
  Writeln('Произведение цифр числа равно ',p)
end.

Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?