Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Kleira
19.07.2022 07:21 •
Информатика
Нужно написать программу подсчитывающую количество чётных и не чётных цифр в числе
Ответ:
anchootka05oz9836
29.07.2020 23:22
//PascalABC.Net 3.0, сборка 1053
var
n: longint;
d, n1, n2: integer;
begin
n1 := 0; n2 := 0;
Write('Введите натуральное число: ');Read(n);
repeat
d := n mod 10;
if odd(d) then Inc(n1) else Inc(n2);
n := n div 10
until n = 0;
Write('Нечетных ', n1, ', четных ', n2)
end.
Тестовое решение:
Введите натуральное число: 3534052
Нечетных 4, четных 3
0,0
(0 оценок)
Популярные вопросы: Информатика
Красотка794
26.02.2020 13:49
Перевод текста с английского языка на русский является прогрпммой...
kasabyan2000
16.11.2021 20:40
Напишите программу: №1 Вводятся координаты 5 различных (все координаты различны) точек на плоскости, через первые 3 проходит окружность (в частном случае прямая) через...
Бекзатажеси
01.08.2021 06:28
Дано описание массива: var a: array [1..27] of integer; здесь oписан массив a из целочисленных значений. при выполнении этого оператора в памяти компьютера будет выделено...
eva170280
11.08.2020 02:47
Как называется ? операция над фрагментом с целью его последующего повторения....
sofitit0410
06.07.2021 01:39
Сочинение на тему зачем современному человеку книги (в том смысле что книги нужны)7 класс...
ооиррррр
06.07.2021 01:39
1)вычисли значения выражений 45+27: 3 - 12 90-36: 3 x 2 84: 4 x 3+2 100-10x9-8 17+15x3x0 5x5+75: 5 17x3+2x10 80-5x2: 10 72: 6+6x5 2)измени порядок действий с скобок и вычисли...
KrasnovaLu82
06.07.2021 01:39
Определение слов. фонетика, фазиология, лексика. : )...
ника11082001
06.07.2021 01:39
Доказать что при всех значениях а верно неравенство: 1) (a+7)(a+1) (a+2)(a+6) 2) (3a-2)(a+2) (1+2a)^2...
УиллСмит
06.07.2021 01:39
Правила поведения в общественном транспорте....
mpaxomow
06.07.2021 01:39
Мяч брошен вертикально вверх с начальной скоростью 9,8 м/c. через какое время его скорось уменьшится до 0 ? какое перемещение совершит при этом мяч?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
n: longint;
d, n1, n2: integer;
begin
n1 := 0; n2 := 0;
Write('Введите натуральное число: ');Read(n);
repeat
d := n mod 10;
if odd(d) then Inc(n1) else Inc(n2);
n := n div 10
until n = 0;
Write('Нечетных ', n1, ', четных ', n2)
end.
Тестовое решение:
Введите натуральное число: 3534052
Нечетных 4, четных 3