В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zab1290
zab1290
12.04.2021 18:31 •  Информатика

Написать программу для вычисления произведения и среднего арифметического чисел от 1 до n, которые: 1) нечётные и кратны 3

Ответ:
olgabogomolova123
olgabogomolova123
02.10.2020 21:30
Uses crt;
var i,b,x,q:integer;
c:real;
var a: array [1..3] of integer;
begin
clrscr;
writeln('Введите числа');
for i:=1 to 3 do
read(a[i]);
q:=1;
for i:=1 to 3 do begin
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then x:=x+1;
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then b:=b+a[i];
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then q:=q*a[i];
c:=b/x;
end;
writeln('Среднее арифметическое = ',c);
writeln('Произведение = ',q);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?