В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
egorkarevyakin
egorkarevyakin
14.02.2022 03:47 •  Информатика

Дано натуральное число n( трехзначное ) составить программу которая вычисляет сумму цифр этого числа

Ответ:
va1k
va1k
29.07.2020 11:49
Код на Паскале:
Program proba;
Uses crt;
Var n,s:integer;
Begin
writeln('введите натуральное число');
Readln(n);
s:=0;
repeat s:=s+n mod 10;  
 n:=n div 10;until n=0;
writeln('сумма цифр ',s);
end.
P.S. Программа вычисляет не только трехзначные числа ;)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?