В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DaniilPedrol
DaniilPedrol
06.12.2021 06:37 •  Информатика

Написать программу на языке паскаль. дано число n. в интервале от 1 до n сложить все числа, которые делятся на 3, и перемножить все, делящиеся на 2.

Ответ:
арсений213
арсений213
29.07.2020 09:53
Var n,a,b,c:integer;
begin
write('введите длину интервала: ');
readln(n);
a:=0;
c:=1;
for b:=1 to n do begin
if (b mod 3 =0) then a:=a+b;
if (b mod 2=0) then c:=c*b;
end;
writeln('сумма делящихся на 3=> ',a);
writeln('произведение делящихся на 2=> ',c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?