В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kristin20
kristin20
18.09.2021 19:22 •  Информатика

1.составьте программу вычисления суммы цифр двузначного числа 2. составьте программу вычисления суммы цифр трёхзначного числа

Ответ:
danielan2003
danielan2003
29.07.2020 07:10
Program znanija;
var a,s:integer;
begin
Read(a);
while a<>0 do 
begin   
s:= s + a mod 10;   
a:= a div 10 
end;
writeln(s);
end.

Работает для многозначных цифр не превышающих integer 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?