В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2K99
2K99
14.05.2023 05:54 •  Информатика

Составьте программу, которая определяет, является ли данное натуральное число простым, и выводит на экран соответствующее сообщение: «да» либо «нет».

Ответ:
pro100leramakh
pro100leramakh
06.06.2020 21:21

program xxx;

var k, d, n : integer;

      pr : boolean;

begin

  writeln('Введите число k=');

  readln(k);

  d:=2;

  n:= k div 2;

  pr:=false;

  while (d<=n) and not(pr) do

     if k mod d = o then pr:=true else d:=d+1;

  if pr then writeln (k, '- нет, число не простое') else writeln (k, ' да,число простое');

   readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?