В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Maer12
Maer12
02.04.2021 01:35 •  Информатика

Информатика, 10 кл. написать программу, определяющую сдачу наименьшим количеством монет.для определения размера сдаваемой сдачи, сначала определить, сколько требуется для этого монет 50 рубл. достоинства, затем 20, 10, 5, 2, 1, пока необходимая сумма не будет набрана.

Ответ:
suchilinaelya
suchilinaelya
02.10.2020 20:17
Var s,d,f,g,h,z,v:integer;
begin
write('Введите остаток');Read(s);
if s > 50 then begin d:= s div 50;s:= s - d * 50;end;
if s > 20 then begin f:= s div 20;s:= s - f * 20;end;
if s > 10 then begin g:= s div 10;s:= s - g * 10;end;
if s > 5 then begin h:= s div 5;s:= s - g * h;end;
if s > 2 then beginz:= s div 2;s:= s - g * z;end;
if s > 1 then beginv:= s div 1;s:= s - g * v;end;
writeln('50p =',d,'  20p =',f,'  10p =',g,'  5p =',h,'  2p =',z,'  1p =',v);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?