Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ArinaYmnaya
22.12.2021 02:35 •
Информатика
+! в одномерном массиве x(15) найти максимальный из элементов, меньше трех, и поменять его местами с предпоследним
Ответ:
Marina11231
28.07.2020 08:17
Const
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
GansikT
23.09.2021 11:45
Написать описание любой операционной системы, кроме OC Windows...
EstrWite
08.06.2020 02:42
Ввести с клавиатуры массив из 5 элементов , найти среднее арифметическое всех элементов масива. abc pascal. через for,,repead...
asdf2033
14.01.2023 23:42
Вычислиите 27262986 бит в Кб,Мб,Гб....
AlisaKalten
19.08.2021 18:26
Спо информатике составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате даст произведение этих чисел (используя два вида циклов)...
LaiZyHero
19.08.2021 18:26
Pascal напишите программу, которая сортирует первую половину массива по возрастанию, а вторую – по убыванию. при этом элементы из первой половины не должны перемещаться...
Черничка21
24.12.2020 16:36
Найдите наименьшее натуральное число, которое при делении на 13 дает остаток 4, а при делении на 8 остаток 3...
jolyy
01.08.2022 09:40
Запишите неправильную дробь в виде смешанной дроби а)3/2, 5/4, 8/5, 7/2, 10/3, 15/4, 53/6, 40/9, б)20/8, 15/10, 28/21, 40/15, 56/12, 42/9, 22/4, 50/6...
veterokttty
10.04.2021 20:58
Can the pronoun “everyone” and “everybody” be used in the genitive (=possessive) case?...
Nice1111111111111
15.01.2022 07:40
Can the pronoun “everything” be used in the genitive case?...
Aydan204
17.04.2023 05:02
Назовите какое значение имеет для россии море...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.