В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ivanow343536373839
ivanow343536373839
21.03.2020 22:36 •  Информатика

Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. p.s формулы в программе быть не должно

Ответ:
SUPERMOZGgg
SUPERMOZGgg
26.05.2020 09:54

var a:string;
i:integer;
c:boolean;
begin
readln(a);
repeat
if pos('+',a)<>0 then begin inc(i); delete(a,pos('+',a),1); end;
if pos('-',a)<>0 then begin inc(i); delete(a,pos('-',a),1); end;
if (pos('+',a)=0) and (pos('-',a)=0) then c:=true;
until c;
writeln(i);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?