Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
натали578
12.04.2022 11:14 •
Информатика
Составить программу вычисления суммы цифр двухзначного числа "a".значение "а",введите с клавиатуры.! надо(буду вам признательна *_*
Ответ:
katy0987
02.10.2020 18:32
Должно работать и для двухзначного и для 3ехзначного и для 99999значного
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
0,0
(0 оценок)
Ответ:
VeronicaOgne
02.10.2020 18:32
Pascal ABC
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Kuса
10.12.2022 04:54
Наименьшим элементом поверхности экрана, для которого могут быть заданы адрес, цвет и интенсивность, является:...
ТупаяСандра
10.01.2021 10:07
Определите значение переменной а после выполнения алгоритма: a:= 9 b:=45 div a b:=b*10 a:=b mod 4 + 3...
corbaov2018
25.05.2022 10:57
Создать программу которая нарисует 10 кругов в ряд в python цвет на ваш выбор...
yvvv
29.04.2023 13:05
В массиве 50 элементов Заполнение организуется через генератор случайных чисел или вводом с клавиатуры (границы от 1 до 1000) Необходимо определить минимальный нечётный элемент...
af1045017202
17.02.2022 04:28
Укажите правильные ответ оператор присваивания обозначается ...
Write23
27.10.2020 11:35
Записать логическое выражение для функции F(X,Y,Z) согласно заданной таблице истинности . Полученное логическое выражение упростить и составить по нему логическую схему....
prostopohelnaxyi
29.10.2022 05:59
9класс тест по теме хранение и обработка информации в базах данных. введите фамилию и имя: , с ! 1. одним из основных типов информационных структур логическая. база данных. строковая....
diana5974767
27.04.2021 01:59
Що розвивається у чоловічих шишках, і що у жіночих ть...
nikita1232534
26.01.2020 16:06
В какую наименьшую группу относится тюльпан и ромашка? есть: отдел цветковые, царство растения, царство цветковые, отдел растения...
engelsvova
27.04.2021 01:59
Вибрация и шум. Сходства и отличия...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.