В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arina1238
arina1238
11.05.2021 05:45 •  Информатика

С. написать программу для : пользователь вводит с клавиатуры величину, выраженную в килобайтах. программа переводит ее в биты и мегабайты. в паскале

Ответ:
oroz9898
oroz9898
26.05.2020 07:36

var x: real;

begin

writeln('Введите число(Кб): ');

readln(x);

writeln(x,' Кб = ',x*1024*8,' бит');

writeln(x,' Кб = ',x*1024,' байт');

writeln(x,' Кб = ',x/1024,' Мб');

end.

0,0(0 оценок)
Ответ:
maxim1213
maxim1213
26.05.2020 07:36

program line_4;

uses crt;

var

kb, b: longint;

mb: real;

begin

clrscr;

write(‘kb (килобайт) = ‘); readln(kb);

b:=kb*1024*8;

mb:=kb/1024;

writeln(kb,‘ килобайт = ‘, b, ‘ бит = ‘, mb:6:4, ‘ мб’);

readkey;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?