В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gladiolys2003
gladiolys2003
17.12.2022 00:30 •  Информатика

Найти среднее арифметическое элементов одномерного массива а10. составить программу.

Ответ:
Dmitr55
Dmitr55
26.05.2020 06:57

Допустим, что все элементы должны быть положительными.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int a[10] = { 5, 2, 8, 21, 17, 9, 0, 3, 1, 2 };
   float mean = 0;

   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ' ';

      mean += a[i]; //Найти сумму всех элементов
   }

   mean /= 10;

   cout << "\nArithmetic mean = " << mean << endl;

   return 0;
}


Найти среднее арифметическое элементов одномерного массива а10. составить программу.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?