В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vikakotova3
vikakotova3
25.05.2022 13:37 •  Информатика

Вычеркните из слова все буквы "я", стоящие на четных местах. написать программу на с++

Ответ:
smile1506
smile1506
02.10.2020 16:59
На вывод работало с 866, а на ввод с 1251 (SetConsoleCP();).
В массив пишет каракули.
Функции  setlocale(LC_CTYPE, "Russian"); setlocale(LC_ALL, "Russian"); тоже не Отлично работают с ОТОБРАЖЕНИЕМ текста в консоли, но с чтение из ее это ужас. 
В С++ всегда с этим проблема была, с обработкой вводимой кириллицы  с консоли.
Это те еще танцы с бубнами. Учитывая еще то, что многие функции писались исключительно под XP а про поддержку в версиях выше речи не было вообще.
Есть выходы конечно, но у меня не получилось отобразить кириллицу, считать с консоли, и вывести обратно. Что-то одно всегда не работало.Либо выводило правильно, а записывало каракули, либо каракули выводит а записывает правильно. 
Если убрать все заморочки с кодировками, то вот код:

int _tmain(int argc, _TCHAR* argv[])
{
setlocale(LC_CTYPE, "Russian");
char *str=new char[]; 
cout<<"Введите слово: "; cin>>str;

   for (int i = 0; i < strlen(str); i++)
    {
       if(str[i]!='я'&&i%2!=0){cout<<str[i];} 
    }

system("PAUSE");

}
Вычеркните из слова все буквы я, стоящие на четных местах. написать программу на с++
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?