В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
11martandreyp0bwg2
11martandreyp0bwg2
08.01.2023 19:22 •  Информатика

Составьте программу, проверяющую есть ли в двумерном массиве a (n,n) столбцы, все элементы которых различны.

Ответ:
али394
али394
24.07.2020 14:59
                      Const n=4;
Var x:array [1..n,1..n] of integer;
k,s,i,j:integer;
begin  
 randomize;   
 for i:=1 to n do begin      
  for j:=1 to n do begin     
       x[i,j] := random(100);      
      write(x[i,j]:6);   
     end;      
  writeln; 
   end; 
  for i := 1 to n do
    for j := 1 to n do   
   for k := j+1 to n do    
    if x[j,i]=x[k,i]
then 
writeln('NO') 
else 
writeln ('YES');
readln;
end.       
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?