В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mjsden80
mjsden80
25.09.2021 15:49 •  Информатика

Составьте программу, выясняющую какая из букв п или в встречается раньше.

Ответ:
Zendydla
Zendydla
24.07.2020 08:33
Var
  str:string;
  i:integer;

begin
  readln(str);
  for i:=1 to Length(str) do
    if ( str[i] = 'П' ) OR ( str[i] = 'В' ) then
      break;
  writeln(str[i]);
end.
0,0(0 оценок)
Ответ:
lopkin
lopkin
24.07.2020 08:33
В Паскале есть стандартная функция Pos, которая возвращает начальную позицию вхождения подстроки в строку или 0, если такое вхождение не обнаружено. С её данная задача решается очень просто.

var
  s:string;
  ip,iv:integer;
begin
  Write('Введите строку: '); Readln(s);
  ip:=Pos('П',s); iv:=Pos('В',s);
  if ip*iv=0 then Writeln('П или В или обе не найдены в тексте')
  else
    if ip<iv then Writeln('П встретилось раньше В')
    else Writeln('В встретилось раньше П')
end.

Тестовое решение:
Введите строку: НА ЛУГУ ПАСЕТСЯ КОРОВА
П встретилось раньше В
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?