В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dianaknyazeva
dianaknyazeva
28.06.2020 06:30 •  Информатика

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. паскаль

Ответ:
frankinshtein228
frankinshtein228
02.10.2020 15:57
Program a1;
var x,y,s: integer;
begin
read (x,y);  
write(x,'*',y,'=');  
while x>0 do 
 begin 
    If ((x mod 2) <>0) then s:=s+y; 
    x:= x div 2;  
   y:=y+y;
 end;
write(s);
writeln();
readln();
end.
Русский умножения
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?