Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
arisha0081
12.01.2023 00:08 •
Информатика
Является ли натуральное число фактор влом некоторого числа. напишите программу,
Ответ:
kamilahamidova
23.07.2020 21:25
#include <iostream>
int fac(int n) {
return n ? n*fac(n - 1) : 1;
}
int main()
{
int n;
std::cin >> n;
for (int i = 1; i < n; ++i) {
if (n == fac(i)){
std::cout << i << "! = " << n;
break;
}
}
return 0;
}
Алгоритм не оптимизирован, но для учебных целей сойдет.
0,0
(0 оценок)
Популярные вопросы: Информатика
DogyStyleee
11.10.2022 22:08
Запишите на языке паскаль: [tex]y=|x^{2} +\frac{x+2.5}{3x}|-3\sqrt{sin2x-\frac{2}{1-x} }[/tex]...
Ksenka3515
05.10.2022 18:20
Мне нужно написать программы на Python: 1) Описать структуру с именем NOTE, содержащую следующие поля: • фамилия, имя; • номер телефона; • дата рождения (массив из трех чисел). Написать...
nekitpundya2256
15.06.2021 21:43
Дан фрагмент электронной таблицы A1=3 B1=? C1= A1+1 A2= B2+A1 B2= B1-2 C2=C1-B1...
liliannaklochko
25.07.2020 03:33
Який рeжим пeрeгляду призначeний для роботи над схeмою докумeнта...
sirghiina
30.07.2021 03:05
Просклоняйте числительные 54, 187, 1998 54 и.п. р.п. д.п. в.п. тв.п. п.п. и так с 187 и 1998...
natalika79
30.07.2021 03:05
9умножить на 4 минус 18 разделить на 2...
Valeriya0412
30.07.2021 03:05
Найдите значение многочлена : 5x(6 степени )-3x²+7-2x (в 6 степени)- 3x (в 6 степени)+4x²...
2006anna1
30.07.2021 03:05
Почему не разъединяются клетки из которых состоит растение...
prvvk
30.07.2021 03:05
Что такое билль о правах и когда он был утвержден?...
T0nystark
30.07.2021 03:05
6. найдите слово с чередующейся гласной а. тр…сина б. к…сательная в. ск…сить г. р…стелить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int fac(int n) {
return n ? n*fac(n - 1) : 1;
}
int main()
{
int n;
std::cin >> n;
for (int i = 1; i < n; ++i) {
if (n == fac(i)){
std::cout << i << "! = " << n;
break;
}
}
return 0;
}
Алгоритм не оптимизирован, но для учебных целей сойдет.