Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
veshiyoleg
26.05.2022 07:56 •
Информатика
Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и удалить k-ый элемент (k = 1 n- любое). пример: исходный массив: 4 -5 3 10 -4 -6 8 -10 1 5 введите число k = 2 результат: 4 3 10 -4 -6 8 -10 1 5
Ответ:
svitaliy360
02.10.2020 15:30
Program a;
var a: array [1..10] of integer;
n,s: integer;
begin
for i:=1 to 10 do begin
a[i]:=random(20)-10;
write(a[i]);
end;
readln(n);
for i:=n to 9 do begin
s:=a[i+1];
a[i+1]:=a[i];
a[i]:=s;
end;
for i:=1 to 9 do
writeln (a[i]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Ингуш03
15.05.2021 15:14
Навколо квитника квадратнои форми потрибно посадити 14 квитив так щоб уздовж кожной сторони була однакова килькисть квитив...
magauiyaa
15.05.2021 15:14
Составьте программу, которая вычисляет произведение чисел от 5 до 10 и выводит на экран ответ исключительно через while...
tolkov05
15.05.2021 15:14
Для чого призначенна панель атрибутів тексту?...
dpichuzhkina
31.10.2020 09:50
Напишите программу которая определяет верно ли что в строке чётное количество букв?...
prozorovamary23
03.05.2023 15:40
Влыжном кроссе участвуют 256 спортсменов. специальное устройство регистрирует прохождения каждым из участников промежуточного финиша, записывая его номер цепочкой...
alyamiller1513
03.05.2023 15:40
Нужно составить блок-схему разветвляющегося алгоритма: 1. даны целые числа x,y определить принадлежит ли точка с координатами [x,y] кругу радиуса r. 2. вычислить корни...
AHOHUM3321
03.05.2023 15:40
Решите мою , т.к завтра первая информатика...
LiraReeman
03.05.2023 15:40
1) перевести числа из десятичной системы счисления в двоичную: 42, 32, 44, 54,7; 2) перевести числа из двоичной системы счисления в десятичную: 10010,10101, 101010,...
10089675834075
03.05.2023 15:40
Сколько существует комбинаций из + и - состоящих из 3-х символов решите...
SofiaShpakivska
31.10.2022 02:10
Даны натуральные числа n, a1 определить количество членов последовательности, являющихся нечетными числами...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a: array [1..10] of integer;
n,s: integer;
begin
for i:=1 to 10 do begin
a[i]:=random(20)-10;
write(a[i]);
end;
readln(n);
for i:=n to 9 do begin
s:=a[i+1];
a[i+1]:=a[i];
a[i]:=s;
end;
for i:=1 to 9 do
writeln (a[i]);
end.